Carros malucos

Constrói carrinhos e bonecos arrastando as peças em baixo para a parte superior.
Não é divertido pô-los a andar?

Este projecto utiliza classes. Se tiveres o Imagina podes explorar e modificar este projecto.

bloco_janela_principal.png

Para criar a classe bloco escrevemos na linha de comandos:

? novaclasse “tartaruga “bloco []

Depois podemos editar e modificar a classe a partir do Explorador na Janela Principal.

Classe bloco Eventos

classe_bloco_eventos.png

Classe bloco Variáveis

  • cores
  • formas
  • autoarrastar
  • caneta

Classe bloco Procedimentos

para meuClone
se Coory > -100
[clone meuNome [aoClicarDireito [rodarClone]
aoLargarEsquerdo [se Coory < -130
[fixapeças semelemento meunome peças
eliminaobjecto meunome]]]

pede últimonome [fixapeças põeúltimo meunome peças]
]
;voltar para casa suavemente
iniciar [
faz "h primeiro estadoinicial
enquanto [abs pos - :h > 1] [fixaPos pos + 0.1 * (:h - pos)
espera 15]
casa]
fim

para minhaForma
fazComum “formas
[[Círculopreenchido 61]
[círculopreenchido 37]
[lc recua 20 esq 90 bc polígono [repete 4 [av 20 dta 90 av 20]]]
[lc recua 30 esq 90 av 7 dta 90 bc polígono [repete 2 [av 60 dta 90 av 15 dta 90]]]
[lc recua 7 esq 90 av 30 dta 90 bc polígono [repete 2 [av 15 dta 90 av 60 dta 90]]]
[lc recua 25 esq 90 bc polígono [repete 3 [av 30 dta 120 av 30]]]
[lc recua 15 esq 90 av 30 dta 90 bc polígono [repete 2 [av 30 dta 90 av 60 dta 90]]]
]
Fim

para mudaCor
fixaCorPinta escolhe cores
fixaforma forma
fim

Procedimentos da JanelaPrincipal

para inicia_jogo
novo “tartaruga [corcaneta cinzento5
pos [0 -130]
rumo 90
visível falso
nome ecrã]
pede “ecrã [av 1000 lc dta 90 av 20
fixacorpinta [255 255 205] pinta]
eliminaobjecto “ecrã
;======cria novos blocos
repete conta bloco’formas
[novo "bloco [pos ([-130 -190] + contador * [65 0])
corpinta (escolhe bloco’cores)
forma (item contador bloco’formas)
]]
;=======Inicializa a lista de peças a criar
fixapeças []
fim

para fim_jogo
eliminaobjecto listade “bloco
le páratudo
fim
para partida
faz “velocidade c1 / 10
faz “treme c2
pedeCada peças [fixaAutoArrastar "falso
fixaEvento "aoClicarEsquerdo []
fazPrópria “P pos]
pede peças [emCada 50
[cada [
fixaP P + frase :velocidade 0
fixaPos P + roda aleatório 360 frase :treme 0]]]
fim

para rodarClone
dta 15
fim


 

Colocado no dia: 17 Junho 2006 às 17:50

Tags:


Comentários


Deixe um Comentário

É necessário estar registado para escrever um comentário.

Caso ainda não se tenha registado poderá registar-se em: http://www.cnotinfor.pt/registo


Subscrever via RSS





  • Comunidade Imagina



  • Criar conta gratuitamente
    Esqueceu a sua password?
    • Print
    • email
    • Twitter
    • Facebook
    • Google Bookmarks
    • del.icio.us
    • LinkedIn
    • RSS



    Áreas

    acessibilidade alfabetização aprendizagem aprendizagem do inglês artigos aventuras Aventuras 2 cidadania ciências comunicar com símbolos comunicação comunicação alternativa educação especial formação geografia história histórias inclusão inVento investigação Já Está já está 2 Laboratórios Virtuais leitura linguagem língua portuguesa línguas estrangeiras mapa de ideias matemática música necessidades especiais NXT pesquisa poesia pt-BR pt-PT quadros interativos robot roamer Robótica sopa decimal soundbeam symbolinc symbol lab símbolos tecnologia assistiva