Listas de desenho como forma da tartaruga

Pode utilizar-se uma lista de desenho como forma da tartaruga, em vez de uma imagem.

Vantagens: rapidez e flexibilidade; rotação e animação sem limitações.

lista_desenho.png

Exemplos:

  • fixacorcaneta qualquer fixatraço 4 polígono [repete 4 [fixacorcaneta qualquer repete 3 [av 60 dta 120] dta 90]]
  • repete 6 [av 30 esq 60]
  • repete 6 [av 30 marca 15 esq 60]
  • fixaTraço 16 fixaCorCaneta 1 av 40
  • fixaTraço 16 fixaCorCaneta 1 av 40 lc dta 90 av 20 dta 90 bc av 40
  • fixaCorCaneta “vermelho5 elipsePreenchida [100 130] lc fixaCorCaneta “azul2 av 20 marca 40
  • fixaCorCaneta “preto círculo 100 lc av 50 fixaCorCaneta “vermelho marca 15 av 24 fixaTipo [|Arial| [10 700 0 0 0 0]] rotula [círculo m2]
  • polígono [repete 5 [av 150 dta 144]]
  • desenhaLinhaCurva [polígono [repete 5 [av 150 dta 144]]]
  • av 100 dta 180 polígono [fixaCorPinta "roxo repete 24 [av 200 dta 165]]
  • polígono [fixaTraço 2 fixaCorPinta "amarelo
    repete 3 [av 100
    polígono [repete 36
    [av 7 dta 10]]
    dta 120]
    ]
  • polígono [fixaTraço 2 fixaCorPinta "vermelho
    desenhaLinhaCurva [repete 3
    [av 125 dta 120]
    ]
    ]

Como pode ser complicado escrever no pequeno espaço visível da caixa Lista de Desenho, podemos optar por criar um procedimento e activá-lo num botão ou na linha de comandos. Para tal é necessário utilizar o comando fixaforma.para

para cria_poli3
t1′fixaforma [polígono
[fixaTraço 2 fixaCorPinta "amarelo
repete 3 [av 100
polígono [repete 36[av 7 dta 10]]
dta 120]
]
]
fim

lista_desenho_exemplos.png

Podemos criar botões que iniciem um processo aoPressionar e parem o mesmo processo aoLargar. Para tal é preciso activar a opção Comutador.

botao_rodar.png

Na ligação Actividade encontra este artigo em formato PDF.


 

Colocado no dia: 25 Fevereiro 2007 às 3:21


Comentários


Deixe um Comentário

É necessário estar registado para escrever um comentário.

Caso ainda não se tenha registado poderá registar-se em: http://www.cnotinfor.pt/registo


Subscrever via RSS





  • Comunidade Imagina



  • Criar conta gratuitamente
    Esqueceu a sua password?
    • Print
    • email
    • Twitter
    • Facebook
    • Google Bookmarks
    • del.icio.us
    • LinkedIn
    • RSS



    Áreas

    acessibilidade alfabetização aprendizagem aprendizagem do inglês artigos aventuras Aventuras 2 cidadania ciências comunicar com símbolos comunicação comunicação alternativa educação especial formação geografia história histórias inclusão inVento investigação Já Está já está 2 Laboratórios Virtuais leitura linguagem língua portuguesa línguas estrangeiras mapa de ideias matemática música necessidades especiais NXT pesquisa poesia pt-BR pt-PT quadros interativos robot roamer Robótica sopa decimal soundbeam symbolinc symbol lab símbolos tecnologia assistiva